Download MUST Connect

Download the latest version

Download the MUST Connect installer for Windows

All the information you need to get started with MUST Connect:

  1. Prerequisites:
    You need Java SE 6, and
    Access to a server hosting a Connect data repository
  2. Run the MUST Connect Browser
  3. Use the data browser

Want to try it out? Contact our sales team for a demo license.